Browse Source

bug 10548: fix count of missing required dependencies by koha_perl_deps.pl

To test:

[1] ./koha_perl_deps.pl -m -u

If you have nothing missing, uninstall an optional component.

[2] ./koha_perl_deps.pl -m -u

You should get a number missing of at least 1.

[3] ./koha_perl_deps.pl -m -u -r

You should get the same number, even though the output is less.

[4] Apply patch

[5] ./koha_perl_deps.pl -m -u

Same results as in step 2.

[6] ./koha_perl_deps.pl -m -u -r

The number should differ from the results in step 3.

Signed-off-by: Galen Charlton <gmc@esilibrary.com>
Signed-off-by: Marcel de Rooy <m.de.rooy@rijksmuseum.nl>
Signed-off-by: Galen Charlton <gmc@esilibrary.com>
new/bootstrap-opac
Mark Tompsett 8 years ago
committed by Galen Charlton
parent
commit
0134341d9a
  1. 3
      koha_perl_deps.pl

3
koha_perl_deps.pl

@ -62,7 +62,6 @@ foreach my $type (@pm) {
print color 'yellow' if $type eq 'upgrade_pm' && $color;
print color 'red' if $type eq 'missing_pm' && $color;
print color 'green' if $type eq 'current_pm' && $color;
$count++;
my $required = ($_->{$pm}->{'required'}?'Yes':'No');
my $current_version = ($color ? $_->{$pm}->{'cur_ver'} :
$type eq 'missing_pm' || $type eq 'upgrade_pm' ? $_->{$pm}->{'cur_ver'}." *" : $_->{$pm}->{'cur_ver'});
@ -73,11 +72,13 @@ format =
$pm, $current_version, $_->{$pm}->{'min_ver'}, $required
.
write;
$count++;
}
}
else {
if (($req && $required eq 'Yes') || !$req) {
print "$pm\n";
$count++;
}
}
}

Loading…
Cancel
Save