Browse Source

Bug 19986: 'Server name' doesn't appear as required

Test plan:
[1.] Go to Admin -> z39.50/SRU servers
[2.] Make a new z39.50 server
[3.] Fill in the required field (hostname, port, database)
[4.] Save the server
[5.] Notice that the form does not submit, tells you that Sever name is
     required
[6.] Repeat steps 2 - 5 but this time make a new SRU server
[6.] Upload the patch and repeat steps 1 - 3 (make a new z39.50 server
     and a new SRRU server)
[7.] See that now 'Server name:' is red and on the right side of the box
     there is a required note
[8.] Save both servers and it should have created a new z39.50 server
and a new SRU server

Signed-off-by: Roch D'Amour <roch.damour@inlibro.com>
Signed-off-by: Julian Maurice <julian.maurice@biblibre.com>

Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org>
18.05.x
Grace Smyth 5 years ago
committed by Jonathan Druart
parent
commit
10c3dc1a25
  1. 4
      koha-tmpl/intranet-tmpl/prog/en/modules/admin/z3950servers.tt

4
koha-tmpl/intranet-tmpl/prog/en/modules/admin/z3950servers.tt

@ -57,8 +57,8 @@
[% END %]
<fieldset class="rows">
<ol>
<li><label for="name">Server name: </label>
<input type="text" name="servername" id="servername" size="65" maxlength="100" value="[% server.servername | html %]"/>
<li><label for="name" class="required">Server name: </label>
<input type="text" name="servername" id="servername" size="65" maxlength="100" value="[% server.servername | html %]" required="required" /> <span class="required">Required</span>
</li>
<li><label for="host" class="required">Hostname: </label> <input type="text" name="host" id="host" size="30" value="[% server.host %]" required="required" /> <span class="required">Required</span>

Loading…
Cancel
Save