Browse Source

Bug 13642 - Remove MARC::Crosswalk::DublinCore from Koha

To test:

1) git grep "MARC::Crosswalk::DublinCore"

C4/Installer/PerlDependencies.pm:    'MARC::Crosswalk::DublinCore' => {
INSTALL.fedora7:MARC::Crosswalk::DublinCore

2) git grep "libmarc-crosswalk-dublincore-perl"

debian/control: libmarc-crosswalk-dublincore-perl,
debian/control: libmarc-crosswalk-dublincore-perl,
install_misc/debian.packages:libmarc-crosswalk-dublincore-perl install
install_misc/ubuntu.10.04.packages:libmarc-crosswalk-dublincore-perl    install
install_misc/ubuntu.12.04.packages:libmarc-crosswalk-dublincore-perl    install
install_misc/ubuntu.packages:libmarc-crosswalk-dublincore-perl  install

3) Repeat step 1 and 2

Signed-off-by: Frederic Demians <f.demians@tamil.fr>
  Ripping out any mention to MARC::Crosswalk::DublinCore can't hurt.

Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org>

Signed-off-by: Brendan A Gallagher <brendan@bywatersolutions.com>
new_12478_elasticsearch
Hector Castro 6 years ago
committed by Brendan A Gallagher
parent
commit
22dbfca235
  1. 5
      C4/Installer/PerlDependencies.pm
  2. 1
      INSTALL.fedora7
  3. 2
      debian/control
  4. 1
      install_misc/debian.packages
  5. 1
      install_misc/ubuntu.10.04.packages
  6. 1
      install_misc/ubuntu.12.04.packages
  7. 1
      install_misc/ubuntu.packages

5
C4/Installer/PerlDependencies.pm

@ -317,11 +317,6 @@ our $PERL_DEPS = {
'required' => '1',
'min_ver' => '5.43'
},
'MARC::Crosswalk::DublinCore' => {
'usage' => 'Core',
'required' => '1',
'min_ver' => '0.02'
},
'CGI::Session::Serialize::yaml' => {
'usage' => 'Core',
'required' => '1',

1
INSTALL.fedora7

@ -746,7 +746,6 @@ MARC::Record
MARC::Charset
MARC::Charset::Constants
MARC::File::XML
MARC::Crosswalk::DublinCore
Net::Z3950::ZOOM
Net::LDAP::Filter
HTML::Template::Pro

2
debian/control

@ -70,7 +70,6 @@ Build-Depends: libalgorithm-checkdigits-perl,
liblwp-protocol-https-perl|libwww-perl (<6.02), libio-socket-ssl-perl,
libmail-sendmail-perl,
libmarc-charset-perl,
libmarc-crosswalk-dublincore-perl,
libmarc-record-perl,
libmarc-xml-perl,
libmemoize-memcached-perl,
@ -278,7 +277,6 @@ Depends: libalgorithm-checkdigits-perl,
liblwp-protocol-https-perl|libwww-perl (<6.02), libio-socket-ssl-perl,
libmail-sendmail-perl,
libmarc-charset-perl,
libmarc-crosswalk-dublincore-perl,
libmarc-record-perl,
libmarc-xml-perl,
libmemoize-memcached-perl,

1
install_misc/debian.packages

@ -74,7 +74,6 @@ liblocale-gettext-perl install
liblocale-po-perl install
libmail-sendmail-perl install
libmarc-charset-perl install
libmarc-crosswalk-dublincore-perl install
libmarc-record-perl install
libmarc-xml-perl install
libmemoize-memcached-perl install

1
install_misc/ubuntu.10.04.packages

@ -101,7 +101,6 @@ liblocale-gettext-perl install
liblocale-po-perl install
libmail-sendmail-perl install
libmarc-charset-perl install
libmarc-crosswalk-dublincore-perl install
libmarc-record-perl install
libmarc-xml-perl install
libmemoize-memcached-perl install

1
install_misc/ubuntu.12.04.packages

@ -105,7 +105,6 @@ liblocale-gettext-perl install
liblocale-po-perl install
libmail-sendmail-perl install
libmarc-charset-perl install
libmarc-crosswalk-dublincore-perl install
libmarc-record-perl install
libmarc-xml-perl install
libmemoize-memcached-perl install

1
install_misc/ubuntu.packages

@ -105,7 +105,6 @@ liblocale-gettext-perl install
liblocale-po-perl install
libmail-sendmail-perl install
libmarc-charset-perl install
libmarc-crosswalk-dublincore-perl install
libmarc-record-perl install
libmarc-xml-perl install
libmemoize-memcached-perl install

Loading…
Cancel
Save