Browse Source

Bug 20016: use Modern::Perl in svc scripts

Test Plan:
- Check that it now says 'use Modern::Perl' and not 'use trict; use
warnings;' in the follwing plugins svc scripts

authentication
bib
bib_profile
checkouts
config/systempreferences
import_bib
new_bib

https://bugs.koha-community.org/show_bug.cgi?id=20016
Signed-off-by: Jon Knight <J.P.Knight@lboro.ac.uk>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>

Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org>
18.05.x
Zoe Bennett 5 years ago
committed by Jonathan Druart
parent
commit
2bde680e0b
  1. 3
      svc/authentication
  2. 3
      svc/bib
  3. 3
      svc/bib_profile
  4. 3
      svc/checkouts
  5. 3
      svc/config/systempreferences
  6. 3
      svc/import_bib
  7. 3
      svc/new_bib

3
svc/authentication

@ -18,8 +18,7 @@
# along with Koha; if not, see <http://www.gnu.org/licenses>.
#
use strict;
use warnings;
use Modern::Perl;
use CGI qw ( -utf8 );
use C4::Auth qw/check_api_auth/;

3
svc/bib

@ -19,8 +19,7 @@
# along with Koha; if not, see <http://www.gnu.org/licenses>.
#
use strict;
use warnings;
use Modern::Perl;
use CGI qw ( -utf8 );
use C4::Auth qw/check_api_auth/;

3
svc/bib_profile

@ -18,8 +18,7 @@
# along with Koha; if not, see <http://www.gnu.org/licenses>.
#
use strict;
use warnings;
use Modern::Perl;
use CGI qw ( -utf8 );
use C4::Auth qw/check_api_auth/;

3
svc/checkouts

@ -17,8 +17,7 @@
# with Koha; if not, write to the Free Software Foundation, Inc.,
# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
use strict;
use warnings;
use Modern::Perl;
use CGI;
use JSON qw(to_json);

3
svc/config/systempreferences

@ -18,8 +18,7 @@
# along with Koha; if not, see <http://www.gnu.org/licenses>.
#
use strict;
use warnings;
use Modern::Perl;
use C4::Context;
use C4::Service;

3
svc/import_bib

@ -18,8 +18,7 @@
# along with Koha; if not, see <http://www.gnu.org/licenses>.
#
use strict;
use warnings;
use Modern::Perl;
use CGI qw ( -utf8 );
use C4::Auth qw/check_api_auth/;

3
svc/new_bib

@ -18,8 +18,7 @@
# along with Koha; if not, see <http://www.gnu.org/licenses>.
#
use strict;
use warnings;
use Modern::Perl;
use CGI qw ( -utf8 );
use C4::Auth qw/check_api_auth/;

Loading…
Cancel
Save