Browse Source

Bug 11757: remove dependency on POE

The last use of the POE family of Perl modules went away with
the removal of zebraqueue_daemon.pl per bug 9001.  Consequently,
this patch removes POE as a dependency.

To test:

[1] Verify that "git grep POE" and "git grep libpoe" report
    nothing.
[2] Verify that koha_perl_deps.pl -a does not report POE
    as a dependency.
[3] (extra credit) verify that Debian packages can be built
    that do not list libpoe-perl as a dependency.

This patch also updates some distro-specific installation
instructions and scripts, but makes no representations about
whether those instructions currently work.

Signed-off-by: Galen Charlton <gmc@esilibrary.com>
Signed-off-by: Chris Cormack <chris@bigballofwax.co.nz>
Signed-off-by: Jonathan Druart <jonathan.druart@biblibre.com>
Signed-off-by: Galen Charlton <gmc@esilibrary.com>
3.16.x
Galen Charlton 8 years ago
parent
commit
b67dac81cc
  1. 5
      C4/Installer/PerlDependencies.pm
  2. 1
      INSTALL.fedora7
  3. 1
      INSTALL.opensuse
  4. 2
      debian/control
  5. 1
      install_misc/debian.packages
  6. 1
      install_misc/ubuntu.10.04.packages
  7. 1
      install_misc/ubuntu.12.04.packages
  8. 1
      install_misc/ubuntu.packages

5
C4/Installer/PerlDependencies.pm

@ -89,11 +89,6 @@ our $PERL_DEPS = {
'required' => '1',
'min_ver' => '1.59'
},
'POE' => {
'usage' => 'Core',
'required' => '1',
'min_ver' => '0.9999'
},
'Email::Date' => {
'usage' => 'Core',
'required' => '1',

1
INSTALL.fedora7

@ -774,7 +774,6 @@ XML::LibXSLT
XML::Simple
YAML::Syck
Unix::Syslog
POE
Date::Calc
CHI
CHI::Driver::Memcached

1
INSTALL.opensuse

@ -857,7 +857,6 @@ The commands show below need to be given one by one, because zypper will always
# zypper install perl-PDF-API2
# zypper install perl-PDF-Reuse
# zypper install perl-PDF-Reuse-Barcode
# zypper install perl-POE
# zypper install perl-32bit
# zypper install perl-SMS-Send
# zypper install perl-Schedule-At

2
debian/control

@ -83,7 +83,6 @@ Build-Depends: libalgorithm-checkdigits-perl,
libpdf-reuse-barcode-perl,
libpdf-reuse-perl,
libpdf-table-perl,
libpoe-perl,
libreadonly-perl,
libreadonly-xs-perl,
libscalar-list-utils-perl,
@ -272,7 +271,6 @@ Depends: libalgorithm-checkdigits-perl,
libpdf-reuse-barcode-perl,
libpdf-reuse-perl,
libpdf-table-perl,
libpoe-perl,
libreadonly-perl,
libreadonly-xs-perl,
libscalar-list-utils-perl,

1
install_misc/debian.packages

@ -94,7 +94,6 @@ libpdf-api2-simple-perl install
libpdf-reuse-barcode-perl install
libpdf-reuse-perl install
libpdf-table-perl install
libpoe-perl install
libreadonly-perl install
libreadonly-xs-perl install
libschedule-at-perl install

1
install_misc/ubuntu.10.04.packages

@ -121,7 +121,6 @@ libpdf-api2-simple-perl install
libpdf-reuse-barcode-perl install
libpdf-reuse-perl install
libpdf-table-perl install
libpoe-perl install
libreadonly-perl install
libreadonly-xs-perl install
libschedule-at-perl install

1
install_misc/ubuntu.12.04.packages

@ -126,7 +126,6 @@ libpdf-api2-simple-perl install
libpdf-reuse-barcode-perl install
libpdf-reuse-perl install
libpdf-table-perl install
libpoe-perl install
libreadonly-perl install
libreadonly-xs-perl install
libschedule-at-perl install

1
install_misc/ubuntu.packages

@ -126,7 +126,6 @@ libpdf-api2-simple-perl install
libpdf-reuse-barcode-perl install
libpdf-reuse-perl install
libpdf-table-perl install
libpoe-perl install
libreadonly-perl install
libreadonly-xs-perl install
libschedule-at-perl install

Loading…
Cancel
Save