Browse Source

Bug 19995: use Modern::Perl in Catalogue perl scripts

Test Plan:
- Check that it now says 'use Modern::Perl;' and not 'use strict; use
warnings;' in the following catalogue perl scripts.

MARCdetail.pl
export.pl
image.pl
imageviewer.pl
issuehistory.pl
labeledMARCdetail.pl
moredetail.pl
search.pl
showmarc.pl
updateitem.pl

Signed-off-by: Jon Knight <J.P.Knight@lboro.ac.uk>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>

Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org>
18.05.x
Zoe Bennett 5 years ago
committed by Jonathan Druart
parent
commit
cea818a56a
  1. 3
      catalogue/MARCdetail.pl
  2. 3
      catalogue/export.pl
  3. 3
      catalogue/image.pl
  4. 3
      catalogue/imageviewer.pl
  5. 3
      catalogue/issuehistory.pl
  6. 3
      catalogue/labeledMARCdetail.pl
  7. 3
      catalogue/moredetail.pl
  8. 3
      catalogue/search.pl
  9. 3
      catalogue/showmarc.pl
  10. 3
      catalogue/updateitem.pl

3
catalogue/MARCdetail.pl

@ -43,8 +43,7 @@ the items attached to the biblio
=cut
use strict;
#use warnings; FIXME - Bug 2505
use Modern::Perl;
use CGI qw ( -utf8 );
use HTML::Entities;

3
catalogue/export.pl

@ -1,6 +1,5 @@
#!/usr/bin/perl
use strict;
#use warnings; FIXME - Bug 2505
use Modern::Perl;
use C4::Record;
use C4::Auth;

3
catalogue/image.pl

@ -23,8 +23,7 @@
#
#
use strict;
use warnings;
use Modern::Perl;
use CGI qw ( -utf8 ); #qw(:standard escapeHTML);
use C4::Context;

3
catalogue/imageviewer.pl

@ -17,8 +17,7 @@
# You should have received a copy of the GNU General Public License
# along with Koha; if not, see <http://www.gnu.org/licenses>.
use strict;
use warnings;
use Modern::Perl;
use CGI qw ( -utf8 );
use C4::Auth;

3
catalogue/issuehistory.pl

@ -16,8 +16,7 @@
# along with Koha; if not, see <http://www.gnu.org/licenses>.
use strict;
#use warnings; FIXME - Bug 2505
use Modern::Perl;
use CGI qw ( -utf8 );
use C4::Auth;

3
catalogue/labeledMARCdetail.pl

@ -17,8 +17,7 @@
# You should have received a copy of the GNU General Public License
# along with Koha; if not, see <http://www.gnu.org/licenses>.
use strict;
use warnings;
use Modern::Perl;
use CGI qw ( -utf8 );
use HTML::Entities;
use MARC::Record;

3
catalogue/moredetail.pl

@ -19,8 +19,7 @@
# along with Koha; if not, see <http://www.gnu.org/licenses>.
use strict;
#use warnings; FIXME - Bug 2505
use Modern::Perl;
use C4::Koha;
use CGI qw ( -utf8 );
use HTML::Entities;

3
catalogue/search.pl

@ -132,8 +132,7 @@ Not yet completed...
=cut
use strict; # always use
#use warnings; FIXME - Bug 2505
use Modern::Perl;
## STEP 1. Load things that are used in both search page and
# results page and decide which template to load, operations

3
catalogue/showmarc.pl

@ -20,8 +20,7 @@
# with Koha; if not, write to the Free Software Foundation, Inc.,
# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
use strict;
use warnings;
use Modern::Perl;
# standard or CPAN modules used
use CGI qw(:standard -utf8);

3
catalogue/updateitem.pl

@ -17,8 +17,7 @@
#
# You should have received a copy of the GNU General Public License
# along with Koha; if not, see <http://www.gnu.org/licenses>.
use strict;
use warnings;
use Modern::Perl;
use CGI qw ( -utf8 );
use C4::Auth;
use C4::Context;

Loading…
Cancel
Save