Browse Source

Bug 16699: Remove requirement from borrowernumberQueryParam

borrowernumberQueryParam shouldn't be required as also changed in Bug 16271.

To test:
1. Don't apply the patch yet, but first minify Swagger and run
   t/db_dependent/api/v1/holds.t
2. Observe that some tests fail with response code 400 when expecting 200.
3. Apply patch and minify Swagger
4. Run t/db_dependent/api/v1/holds.t
5. Observe that tests pass.

Signed-off-by: Benjamin Rokseth <benjamin.rokseth@kul.oslo.kommune.no>
Signed-off-by: Tomas Cohen Arazi <tomascohen@theke.io>

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
16.11.x
Lari Taskula 6 years ago
committed by Kyle M Hall
parent
commit
eeab7d0666
  1. 1
      api/v1/swagger/parameters/patron.json

1
api/v1/swagger/parameters/patron.json

@ -10,7 +10,6 @@
"name": "borrowernumber",
"in": "query",
"description": "Internal borrower identifier",
"required": true,
"type": "integer"
}
}

Loading…
Cancel
Save