Browse Source

Bug 20009: use Modern::Perl in Members perl scripts

Test Plan:
Check the following files have been updated from
use strict;
use warnings;
to
use Modern::Perl;

boraccount.pl
default_messageprefs.pl
deletemem.pl
files.pl
mancredit.pl
maninvoice.pl
member-flags.pl
member-password.pl
memberentry.pl
members-home.pl
members-update-do.pl
moremember.pl
notices.pl
pay.pl
paycollect.pl
printfeercpt.pl
printinvoice.pl
printslip.pl
readingrec.pl
routing-lists.pl
setstatus.pl
update-child.pl

Signed-off-by: Jon Knight <J.P.Knight@lboro.ac.uk>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>

Signed-off-by: Jonathan Druart <jonathan.druart@bugs.koha-community.org>
18.05.x
Te Rauhina Jackson 5 years ago
committed by Jonathan Druart
parent
commit
f2502c9499
  1. 3
      members/boraccount.pl
  2. 3
      members/default_messageprefs.pl
  3. 3
      members/deletemem.pl
  4. 3
      members/files.pl
  5. 3
      members/mancredit.pl
  6. 3
      members/maninvoice.pl
  7. 3
      members/member-flags.pl
  8. 3
      members/member-password.pl
  9. 3
      members/memberentry.pl
  10. 3
      members/members-home.pl
  11. 3
      members/members-update-do.pl
  12. 3
      members/moremember.pl
  13. 3
      members/notices.pl
  14. 3
      members/pay.pl
  15. 3
      members/paycollect.pl
  16. 3
      members/printfeercpt.pl
  17. 3
      members/printinvoice.pl
  18. 3
      members/printslip.pl
  19. 3
      members/readingrec.pl
  20. 3
      members/routing-lists.pl
  21. 3
      members/setstatus.pl
  22. 3
      members/update-child.pl

3
members/boraccount.pl

@ -22,8 +22,7 @@
# You should have received a copy of the GNU General Public License
# along with Koha; if not, see <http://www.gnu.org/licenses>.
use strict;
use warnings;
use Modern::Perl;
use C4::Auth;
use C4::Output;

3
members/default_messageprefs.pl

@ -18,8 +18,7 @@
# along with Koha; if not, see <http://www.gnu.org/licenses>.
#
use strict;
use warnings;
use Modern::Perl;
use C4::Service;
use C4::Form::MessagingPreferences;

3
members/deletemem.pl

@ -21,8 +21,7 @@
# You should have received a copy of the GNU General Public License
# along with Koha; if not, see <http://www.gnu.org/licenses>.
use strict;
#use warnings; FIXME - Bug 2505
use Modern::Perl;
use CGI qw ( -utf8 );
use C4::Context;

3
members/files.pl

@ -17,8 +17,7 @@
# You should have received a copy of the GNU General Public License
# along with Koha; if not, see <http://www.gnu.org/licenses>.
use strict;
use warnings;
use Modern::Perl;
use CGI qw ( -utf8 );

3
members/mancredit.pl

@ -22,8 +22,7 @@
# You should have received a copy of the GNU General Public License
# along with Koha; if not, see <http://www.gnu.org/licenses>.
use strict;
use warnings;
use Modern::Perl;
use C4::Auth;
use C4::Output;

3
members/maninvoice.pl

@ -22,8 +22,7 @@
# You should have received a copy of the GNU General Public License
# along with Koha; if not, see <http://www.gnu.org/licenses>.
use strict;
use warnings;
use Modern::Perl;
use C4::Auth;
use C4::Output;

3
members/member-flags.pl

@ -4,8 +4,7 @@
# Written by Steve Tonnesen
# July 26, 2002 (my birthday!)
use strict;
use warnings;
use Modern::Perl;
use CGI qw ( -utf8 );
use C4::Output;

3
members/member-password.pl

@ -4,8 +4,7 @@
#by chris@katipo.co.nz
#converted to using templates 3/16/03 by mwhansen@hmc.edu
use strict;
use warnings;
use Modern::Perl;
use C4::Auth;
use Koha::AuthUtils;

3
members/memberentry.pl

@ -19,8 +19,7 @@
# along with Koha; if not, see <http://www.gnu.org/licenses>.
# pragma
use strict;
use warnings;
use Modern::Perl;
# external modules
use CGI qw ( -utf8 );

3
members/members-home.pl

@ -16,8 +16,7 @@
# You should have received a copy of the GNU General Public License
# along with Koha; if not, see <http://www.gnu.org/licenses>.
use strict;
use warnings;
use Modern::Perl;
use CGI qw ( -utf8 );
use C4::Auth;

3
members/members-update-do.pl

@ -16,8 +16,7 @@
# You should have received a copy of the GNU General Public License
# along with Koha; if not, see <http://www.gnu.org/licenses>.
use strict;
use warnings;
use Modern::Perl;
use CGI qw ( -utf8 );
use C4::Auth;

3
members/moremember.pl

@ -33,8 +33,7 @@
=cut
use strict;
#use warnings; FIXME - Bug 2505
use Modern::Perl;
use CGI qw ( -utf8 );
use HTML::Entities;
use C4::Context;

3
members/notices.pl

@ -19,8 +19,7 @@
# You should have received a copy of the GNU General Public License
# along with Koha; if not, see <http://www.gnu.org/licenses>.
use strict;
#use warnings; FIXME - Bug 2505
use Modern::Perl;
use C4::Auth;
use C4::Output;
use CGI qw ( -utf8 );

3
members/pay.pl

@ -26,8 +26,7 @@
=cut
use strict;
use warnings;
use Modern::Perl;
use URI::Escape;
use C4::Context;

3
members/paycollect.pl

@ -17,8 +17,7 @@
# You should have received a copy of the GNU General Public License
# along with Koha; if not, see <http://www.gnu.org/licenses>.
use strict;
use warnings;
use Modern::Perl;
use URI::Escape;
use C4::Context;
use C4::Auth;

3
members/printfeercpt.pl

@ -22,8 +22,7 @@
# You should have received a copy of the GNU General Public License
# along with Koha; if not, see <http://www.gnu.org/licenses>.
use strict;
use warnings;
use Modern::Perl;
use C4::Auth;
use C4::Output;

3
members/printinvoice.pl

@ -20,8 +20,7 @@
# You should have received a copy of the GNU General Public License
# along with Koha; if not, see <http://www.gnu.org/licenses>.
use strict;
use warnings;
use Modern::Perl;
use C4::Auth;
use C4::Output;

3
members/printslip.pl

@ -32,8 +32,7 @@
=cut
use strict;
#use warnings; FIXME - Bug 2505
use Modern::Perl;
use CGI qw ( -utf8 );
use C4::Context;
use C4::Auth qw/:DEFAULT get_session/;

3
members/readingrec.pl

@ -20,8 +20,7 @@
# You should have received a copy of the GNU General Public License
# along with Koha; if not, see <http://www.gnu.org/licenses>.
use strict;
use warnings;
use Modern::Perl;
use CGI qw ( -utf8 );

3
members/routing-lists.pl

@ -17,8 +17,7 @@
# You should have received a copy of the GNU General Public License
# along with Koha; if not, see <http://www.gnu.org/licenses>.
use strict;
#use warnings; FIXME - Bug 2505
use Modern::Perl;
use CGI qw ( -utf8 );
use C4::Output;
use C4::Auth qw/:DEFAULT/;

3
members/setstatus.pl

@ -23,8 +23,7 @@
# You should have received a copy of the GNU General Public License
# along with Koha; if not, see <http://www.gnu.org/licenses>.
use strict;
use warnings;
use Modern::Perl;
use CGI qw ( -utf8 );
use C4::Context;

3
members/update-child.pl

@ -26,8 +26,7 @@
=cut
use strict;
#use warnings; FIXME - Bug 2505
use Modern::Perl;
use CGI qw ( -utf8 );
use C4::Context;
use C4::Auth;

Loading…
Cancel
Save