Bug 6209 [Revised] Standardize on one plugin for client-side form validation
[koha.git] / koha-tmpl / intranet-tmpl / prog / en / includes / validator-strings.inc
1 <script type="text/javascript">
2 //<![CDATA[
3 $(document).ready(function(){
4     jQuery.extend(jQuery.validator.messages, {
5         required: "This field is required.",
6         remote: "Please fix this field.",
7         email: "Please enter a valid email address.",
8         url: "Please enter a valid URL.",
9         date: "Please enter a valid date.",
10         dateISO: "Please enter a valid date (ISO).",
11         number: "Please enter a valid number.",
12         digits: "Please enter only digits.",
13         equalTo: "Please enter the same value again.",
14         maxlength: $.validator.format("Please enter no more than {0} characters."),
15         minlength: $.validator.format("Please enter at least {0} characters."),
16         rangelength: $.validator.format("Please enter a value between {0} and {1} characters long."),
17         range: $.validator.format("Please enter a value between {0} and {1}."),
18         max: $.validator.format("Please enter a value less than or equal to {0}."),
19         min: $.validator.format("Please enter a value greater than or equal to {0}.")
20     });
21 });
22 //]]>
23 </script>