Bug 9259: Use is instead of is_deeply
[koha.git] / plugins / plugins-home.pl
1 #!/usr/bin/perl
2
3 # Copyright 2010 Kyle M Hall <kyle.m.hall@gmail.com>
4 #
5 # This file is part of Koha.
6 #
7 # Koha is free software; you can redistribute it and/or modify it
8 # under the terms of the GNU General Public License as published by
9 # the Free Software Foundation; either version 3 of the License, or
10 # (at your option) any later version.
11 #
12 # Koha is distributed in the hope that it will be useful, but
13 # WITHOUT ANY WARRANTY; without even the implied warranty of
14 # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 # GNU General Public License for more details.
16 #
17 # You should have received a copy of the GNU General Public License
18 # along with Koha; if not, see <http://www.gnu.org/licenses>.
19
20 use strict;
21 use warnings;
22
23 use CGI qw ( -utf8 );
24
25 use Koha::Plugins;
26 use C4::Auth;
27 use C4::Output;
28 use C4::Debug;
29 use C4::Context;
30
31 my $plugins_enabled = C4::Context->preference('UseKohaPlugins') && C4::Context->config("enable_plugins");
32
33 my $input  = new CGI;
34 my $method = $input->param('method');
35
36 my ( $template, $borrowernumber, $cookie ) = get_template_and_user(
37     {   template_name => ($plugins_enabled) ? "plugins/plugins-home.tt" : "plugins/plugins-disabled.tt",
38         query         => $input,
39         type          => "intranet",
40         authnotrequired => 0,
41         flagsrequired   => { plugins => '*' },
42         debug           => 1,
43     }
44 );
45
46 if ($plugins_enabled) {
47
48     $template->param(
49         koha_version => C4::Context->preference("Version"),
50         method       => $method,
51     );
52
53     my @plugins = Koha::Plugins->new()->GetPlugins($method);
54
55     $template->param( plugins => \@plugins, );
56
57 }
58
59 output_html_with_http_headers( $input, $cookie, $template->output );